BankID and Java plug-in in Firefox on Ubuntu Part 3

I recently updated to Ubuntu 9.10. The new Ubuntu version comes with a lot of new packages, including a new version of Java (6.16). Unfortunately, the newest Java plugin from Sun for Thunderbird depends on version 6.15. As a consequence, you’ll get an error message like the one below if you try to install the Java plugin. In this case when you try to open your BankID (which is a Java application). I have had a few problems with BankID on Ubuntu before as well.

Error message:
The following packages have unmet dependencies:
sun-java6-plugin: Depends: sun-java6-bin (= 6-15-1) but 6-16-0ubuntu1.9.04 is to be installed
E: Broken packages

To fix it, I removed the java implementation through the following commands (thanks to FrostCake):
sudo apt-get remove sun-java6-jre sun-java6-plugin sun-java6-bin sun-java6-fonts
sudo apt-get autoremove

Then I reinstalled the sun-java6-plugin through the Synaptic Manager. This will also install all packages which the Java plugin depends on.





i f l
  • RSS
  • Facebook
  • Google+
  • LinkedIn
  • Twitter
  • IMDb
  • Slider